Excel est un outil avec lequel nous pouvons effectuer pléthore de calculs, des plus simples au plus compliqués.

Dans ce tutoriel, nous nous concentrons sur la fonction SI d’Excel. Chaque formule est illustrée par un exemple de situation mais bien sûr elle s’adapte aux besoins de chacun.

Qu’est-ce que la fonction SI ?

La fonction SI sert à déterminer si une condition est remplie ou non, et si elle ne l’est pas alors une autre condition, créée par l’utilisateur, est prévue.

En résumé, elle permet de réaliser des comparaisons logiques entre une valeur et le résultat attendu. Cette fonction peut donc avoir deux résultats car si le premier résultat est avéré alors il doit être appliqué. S’il ne l’est pas alors c’est le 2ème qui le sera.

La formule logique est Si une donnée est vraie, alors appliquons cette solution, sinon appliquons une autre solution. Par exemple, s’il pleut, alors fermons les fenêtres, sinon laissons‑les ouvertes.

La syntaxe d’Excel ou la structure de cette formule SI se présente comme ceci : =SI(test_logique,valeur_si_vraie, valeur_si_fausse).

Notifications de retard

Dans notre première feuille de calcul, le comptable d’une entreprise doit vérifier si chaque paiement a été reçu à la date prévue ou non.

La date d'échéance est indiquée dans la colonne A, l’état du paiement figure dans la colonne B et le nom du client est dans la colonne C.

1- Dans la colonne A, cellule A1, entrez la formule : =AUJOURDHUI(), pour afficher la date du jour.

2- Dans la colonne B, cellule B4, entrez la formule : SI(A4-AUJOURDHUI()>30;"Retard";"OK").

Elle servira à déterminer quels sont les clients en retard de paiement de plus de 30 jours.

En d’autres termes, la formule signifie : Si la date dans la cellule A4 moins la date d'aujourd'hui est supérieure à 30 jours, alors entrez "En retard" dans la cellule B4, sinon, entrez "OK".

3- Il ne vous reste plus qu’à glisser votre curseur de la cellule B4 jusqu’à la cellule B13 pour appliquer la formule partout.

Réussite/Échec à une formation interne

Pour compléter une formation interne, des employés doivent passer un test.

Les candidats qui totalisent un score inférieur à 70 % échouent à l’examen, s’il est supérieur alors ils la réussissent.

1- Dans la colonne A, listez les noms de tous les candidats.

2- Dans la colonne B, reportez leur résultat.

3- Dans la colonne C, il sera affiché la réussite ou l’échec de l’examen. Cette information est obtenue grâce à la fonction SI.

4- Dans la cellule C4, entrez la formule : =SI(B4<70;"Echec";"Réussite").

Cela signifie que si le résultat dans la cellule B4 est inférieur à 70 alors entrez "Echec", sinon entrez "Réussite".

Il ne vous reste plus qu'à glisser votre curseur jusqu’à la cellule C13.

Les fonctions SI imbriquées

Dans cet exemple, nous allons convertir des notes d’examen chiffrées en lettres grâce à des formules SI imbriquées. Ceci consiste à joindre plusieurs fonctions dans une même formule.

Le nom des étudiants est inscrit dans la colonne A, leurs notes chiffrées dans la B et leur équivalent en lettres, calculés grâce aux fonctions SI, seront dans la colonne D.

Nous avons entré dans la cellule C7, la formule suivante :

=SI(B7>16;"A";SI(B7>13;"B";SI(B7>12;"C";SI(B7>8;"D";"E"))))

Il vous suffit ensuite de glisser votre curseur jusqu’à la dernière cellule du tableau.

Notez que chaque parenthèse ouverte doit être fermée à la fin de la fonction.

Commissions sur les ventes et bonus

Les entreprises Wilcox rétribue 10 % de commission à leur équipe marketing si elle parvient à réaliser plus 10 000 euros de vente. Si le montant est inférieur alors elle ne perçoit pas de bonus.

1- Saisissez dans la colonne A le nom de chaque membre de l’équipe marketing.

2- Dans la colonne B, entrez le montant total des ventes réalisées dans le mois.

3- Dans la colonne C, multipliez le total des ventes par 10 %, c’est-à-dire =SOMME(B4*10%). Glissez le curseur de la C4 à C13.

4- Enfin, dans la colonne D entrez la formule =SI(B4>10000;C4;"Pas de Bonus").

Il sera alors affiché le montant de la commission en €, s’il est supérieur à 10 000 €, ou "Pas de Bonus".

Puis, glissez votre curseur de D4 à D13.

5- À présent, pour calculer le total des bonus, entrez dans la colonne D15 =SOMME(D4:D13) et appuyez sur la touche Entrée.

Commissions en pourcentage et fonctions imbriquées

Dans cet exemple, nous allons utiliser une autre technique de fonction SI imbriquée. Celle-ci permet de calculer plusieurs pourcentages de commissions, puis d’effectuer les totaux de ces commissions mensuelles.

1- Dans la colonne A, se trouve le nom des membres de l’équipe marketing.

2- Dans la colonne B est reporté chaque montant total des ventes réalisé sur le mois.

3- Dans la colonne C, sont entrées les commissions.

4- Dans la cellule C4, entrez la formule suivante: =SI(B4<5000;B4*7%;SI(B4<8000;B4*10%;SI(B4<10000;B4*12,5%;B4*15%)))

5- Enfin dans la cellule C15, sera inscrit le montant total calculé automatiquement avec la fonction SI.

Entrez dans C15, la formule : =SOMME(C4:C13).

Prix d’un produit calculé sur la base de la quantité

Beaucoup de revendeurs, et surtout les grossistes, donnent à leurs clients un devis basé sur la quantité de produits.

Par exemple, un grossiste peut vendre 1 à 10 T-shirts à 10,50 €, et 11 à 25 T-shirts à 8,75 €.

Utilisez la formule suivante, pour déterminer les économies que vous allez réaliser en achetant des produits en gros  :

1- Nommez la cellule A3 Prix en gros, la cellule B3 Quantité et la cellule C3 Coût.

2- De B4 à B9, entrez les différentes quantités et leur prix respectif dans la colonne C.

3- À présent, créez un deuxième tableau avec les produits  à vendre (A12 à A18), la quantité commandée (B12 à B18).

4- Enfin, nommez la cellule C11 Coût à la quantité et dans la cellule juste dessous, entrez la formule :

=B13*SI(B13>=101;3,95;SI(B13>=76;5,25;SI(B13>=51;6,3;SI(B12>=26;7,25; SI(B13>=11;8;SI(B13>=1;8,5))))))

5- Pour finir, entrez dans la cellule pour le montant total : =SOMME(C13:C19).

Si vos tarifs et quantités viennent à changer, il suffira d’entrer ces données, Excel va ajuster les formules et calculs.

Utiliser d’autres formules dans la fonction SI

Dans cet exemple, nous allons imbriquer 2 fonctions SI et y insérer la formule SOMME. Le but est de déterminer si les objectifs d’une personne sont inférieurs, équivalents à, ou supérieur à ceux de l’entreprise.

1- Entrez dans la cellule B1 l’Objectif Mensuel. Il peut être modifié chaque mois afin de refléter les attentes de l’entreprise.

2- Nommez les cellules A3 à G3 comme suit : Objectifs, 1er Trim, 2nd Trim, 3ème Trim, 4ème Trim, Objectifs et Bonus.

3- De la cellule A4 à A8, entrez les objectifs des 5 meilleurs membres de l’équipe marketing.

4- Enfin, entrez les totaux trimestriels de chaque commercial, à partir de la cellule B4 jusqu’à la E8.

Ceux qui ont atteint leurs objectifs de ventes gagneront 10 % de bonus du montant total en euros.

Pour ceux qui les ont dépassés, le bonus sera de 25 %.

Voici comment calculer, respectivement, les objectifs et les bonus en € : 

5- Entrez dans la cellule F4, =SI(A4<=B1,A4,SI(A4>B1,SOMME(B4:E4,0))) et glissez-la jusqu’à la cellule F8.

6- Puis, dans la cellule G4, entrez : =SI(F4<=A4,F4*10%,SI(F4>=B1,F4*25%,0)) et glissez‑la jusqu'à G8.

Utiliser la fonction SI pour éviter de diviser par zéro

Dans Excel, lorsque vous essayez de diviser un nombre par zéro, il apparaît le message d’erreur : #DIV/0!.

Alors comment faire si vous avez une importante base de données qui requiert des divisions, et que certaines cellules contiennent le chiffre zéro ? La solution est la fonction SI.

1- Pour calculer l’argent collecté chaque mois par les volontaires de l’organisation caritative, (que nous avons inventée) Espoir et Vie, nommez 4 colonnes de votre tableau ainsi : A1 Euros, B1 Nbre (nombre) de volontaires, C1 Euros par les volontaires et D1 Euros restant.

Le montant entré dans la colonne A sera divisé ensuite entre chaque volontaire.

Le nombre de volontaire peut être 0 car certains jours l’organisation est fermée.

2- Dans la cellule C2, jusqu’à la C11, entrez : =SI(B2<>0.A2/B2.0). Vous verrez que grâce à la fonction SI, il est possible de diviser vos montants par zéro.

3- Dans la cellule D2, copiez la formule =SI(B4=0;A4;0) et glissez-la jusqu’à D11. S’il n’y a pas de volontaire, alors aucune somme ne sera reversée.

4- Maintenant, allez dans B2 et saisissez =MAX(B2:B11), cela sert à repérer le nombre maximal de volontaires, qui est de 8.

5- Pour finir, dans la cellule D12 tapez =SOMME(D2:D11)/B12.
Au total, les 8 volontaires se partageront 392,50 €.

Pour aller plus loin

Si vous souhaitez utiliser Excel et les autres outils Office sur un Mac, n’hésitez pas à consulter notre tutoriel.

Si vous voulez approfondir vos compétences bureautiques, il existe des formations en ligne via l’application gratuite Excel et sur PC à 7,89 €.

Depuis LinkedIn,vous pouvez vous former gratuitement pendant un mois à Excel, Outlook, Word, PowerPoint.

Sachez qu’il existe également des Certifications Microsoft Office.